package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ims)\[([a-zA-Z]\w*)|([^=\s]+)=["'](.*?)["']`)
var str = `Hello, My name is Jack, This is my selfie:
[img id='b' src="imageurl" card="asd"]
Below is the quick-link to my profile
[profile username='jackisbest']
[sometag someatt='value' temp="qwetry']`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}