const regex = /\b(\w)\w+(?:(?:\s+\w+)*?\s+\1\w+){3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\w)\\w+(?:(?:\\s+\\w+)*?\\s+\\1\\w+){3}', 'gm')
const str = `cat take boom candle creepy drum cheek
cat color coral chat
c c c c
ca c ca c ca c ca`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}