$re = '/\b(\w)\w+(?:(?:\s+\w+)*?\s+\1\w+){3}/m';
$str = 'cat take boom candle creepy drum cheek
cat color coral chat
c c c c
ca c ca c ca c ca';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);