#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\{color[^}]*\})|(\![^!]*(thumbnail)\!)|(^\|[\ \h]*)|(\|[\ ]*(?=[\n\r]))"
Local $sString = ""####  [MAINT-170 Setup a virtual IOS Development Environment](https://secure.spiria.com/jira-staging/browse/MAINT-170)####" & @CRLF & _
" **Description** " & @CRLF & _
"| |" & @CRLF & _
"| |" & @CRLF & _
"| |" & @CRLF & _
"|!https://www.pagerduty.com/wp-content/uploads/2016/05/pagerduty-logo-green.png!|[{color:#999999}shutterstock.pagerduty.com{color}|https://shutterstock.pagerduty.com/incidents]|" & @CRLF & _
"| |" & @CRLF & _
"| |" & @CRLF & _
"|Hello Don Ramsey, you have one open incident assigned to you:|" & @CRLF & _
" " & @CRLF & _
"|{color:#767676}Incident #149053{color}|" & @CRLF & _
"| |" & @CRLF & _
"|[CRITICAL: 'check_renewal_tracking' on 'prod-worker16.ma01.bigstockcorp.net'|https://shutterstock.pagerduty.com/incidents/P4HX6H1]|" & @CRLF & _
"| |" & @CRLF & _
"|[{color:#333333}View Incident{color}|https://shutterstock.pagerduty.com/incidents/P4HX6H1]|" & @CRLF & _
"| |" & @CRLF & _
"|{color:#767676}Details{color}|" & @CRLF & _
"|pd_nagios_object: service CONTACTPAGER: 5bb546134cb64acb845ebdf05fc3ae6b|" & @CRLF & _
"| |" & @CRLF & _
"|{color:#767676}Status{color}|" & @CRLF & _
"|{color:#fc0f03}Triggered{color}|" & @CRLF & _
"| |" & @CRLF & _
"|{color:#767676}Urgency{color}|" & @CRLF & _
"|↑ High|" & @CRLF & _
"| |" & @CRLF & _
"|{color:#767676}Assigned To{color}|" & @CRLF & _
"|[{color:#005c9c}Don Ramsey{color}|https://shutterstock.pagerduty.com/users/PAHPTR7]|" & @CRLF & _
"| |" & @CRLF & _
"|{color:#767676}Opened On{color}|" & @CRLF & _
"|[{color:#000000}Oct 24, 2017 at 11:03 AM (Eastern Time (US & Canada)) {color}\|]|" & @CRLF & _
"| |" & @CRLF & _
"|{color:#767676}Service{color}|" & @CRLF & _
"|[{color:#005c9c}nagios (Bigstock){color}|https://shutterstock.pagerduty.com/services/PVF3TQU]|" & @CRLF & _
"| |" & @CRLF & _
"|{color:#767676}Escalation Policy{color}|" & @CRLF & _
"|[{color:#005c9c}Bigstock Team Escalation{color}|https://shutterstock.pagerduty.com/escalation_policies#PYK0IBT]|" & @CRLF & _
"| |" & @CRLF & _
"| |" & @CRLF & _
"|You can disable these messages (or turn off HTML emails) by adjusting [{color:#005c9c}your notification rules{color}|https://shutterstock.pagerduty.com/users/PAHPTR7].|" & @CRLF & _
"| | |" & @CRLF & _
"| |" & @CRLF & _
"|{color:#767676}PagerDuty, Inc., 600 Townsend St., #200, San Francisco, California, 94103 Copyright © 2008 — 2017 PagerDuty, Inc. All rights reserved.{color}|" & @CRLF & _
"| |" & @CRLF & _
"" & @CRLF & _
" ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")