# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d*[^\W\d_][^\W_]*//gm;t' <<< "win32 backdoor guid:64664646 DNS-lookup h0lla 1234 12.356 jhdsjdhs_jdshjdshds"