$re = '/\<(\w+)(?:\s[^<>]+)?\>(?!(?:.|\n)*\<\/\1\>)/';
$str = '<a href="a_url" class="url" target="_blank">
<img ng-src=" {{getImageUrl(\'homeHelp64.jpg\')}}" alt="?" width="16" height="16">
<alt>
</aldt> // invalid
</imgv> // invalid
</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);