use strict;
my $str = '1: How old am I?
A: 8 days
B: 75
C: 100
D: 99correct
xxxxxxxxxxxx
2: What is your favorite color?
A: blue
B: greencorrect
C: red
D: blue
xxxxxxxxxxxx';
my $regex = qr/([A-D]:[\w ]*correct)/mp;
my $subst = 'xxxxxxxxxxxx \\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";