import Foundation
let pattern = #"^(?<amount>.*?)\s*\b(?<unit>tsp|teaspoon|packet|ounces|fl\.\s*ounces|fl\.\s*ounce|cup)\b\s*(?<content>.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
2 fl. ounces paprika
3/4 fl.ounce paprika
1 Chopped Tomato
1/2 Cup yogurt
unclear amount of whatever
1 packet pasta
½ tsp fine sea salt
3 sliced onions
1/2 teaspoon heavy cream
2 ounces paprika
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)