# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Else(?!If)[ \t]*;?/\} else \{ /gm;t' <<< "Else ;
Else
Else ;//------------------------------------------------------
//ElseIf TPlayer(ob) && TPlayer(ob).ProcessLine(Line)
//ElseIf bc=2
//Else
Else ;//ну вообще большой взрыв
"