use strict;
my $str = 'Else ;
Else
Else ;//------------------------------------------------------
//ElseIf TPlayer(ob) && TPlayer(ob).ProcessLine(Line)
//ElseIf bc=2
//Else
Else ;//ну вообще большой взрыв
';
my $regex = qr/Else(?!If)[ \t]*;?/mp;
my $subst = '\\} else \\{ ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";