// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).+('[a-zA-Z\s\/ã]+').+(\$[a-z_]+).+('[0-9%]+').+").unwrap();
let string = " $this->form->addQuickField('Id', $id, '50%' );
$this->form->addQuickField('Nome', $nome, '100%' , new TRequiredValidator);
$this->form->addQuickField('Cpf/Cnpj', $cpf_cnpj, '100%' );
$this->form->addQuickField('Biometria', $senha_biometria, '100%' );
$this->form->addQuickField('Data Inicio Pausa', $data_inicio_pausa, '50%' );
$this->form->addQuickField('Data Fim Pausa', $data_fim_pausa, '50%' );
$this->form->addQuickField('Data Nasc Fundacao', $data_nasc_fundacao, '50%' );
$this->form->addQuickField('Mãe', $mae, '100%' , new TRequiredValidator);
$this->form->addQuickField('Pai', $pai, '100%' );
$this->form->addQuickField('Nascimento', $data_nascimento, '50%' , new TRequiredValidator);
$this->form->addQuickField('Rg', $rg, '100%' );
$this->form->addQuickField('Orgão Expedidor', $sigla_orgao_expedidor, '100%' );
$this->form->addQuickField('Conf Pessoa Tipo Id', $conf_pessoa_tipo_id, '50%' );
$this->form->addQuickField('Conf Pessoa Tipo Documento Id', $conf_pessoa_tipo_documento_id, '50%' );
$this->form->addQuickField('Conf Geral Status Id', $conf_geral_status_id, '50%' );
$this->form->addQuickField('System User Id', $system_user_id, '50%' );
$this->form->addQuickField('Conf End Cidades Id', $conf_end_cidades_id, '50%' );
$this->form->addQuickField('Conf End Estados Id', $conf_end_estados_id, '50%' );
$this->form->addQuickField('Conf Sexos Id', $conf_sexos_id, '50%' );";
let substitution = "\\t$this->form->addFields(\\n\\t\\t[ new TLabel($1) ]\\n\\t\\t,[$2]\\n\\t);\\n\\t$2->setSize($3);\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}