package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+\[([^][]+|(?R))(?:,\s*((?1)))+\]`)
var str = `Tuple[Union[file.File, directory.Directory, Tuple[file.File, directory.Directory]], Tuple[file.File, directory.Directory]]
Tuple[int,int]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}