#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\S\r\n]*(.*\bMISSILE \d.*(?:\r?\n(?!.*\b(?:MISSILE|A\/C) \d).*)*\r?\n[ ]+A\/C[ ]+[0-9]{1,2}[ ]+IS[ ]+KILLED[ ]+AT[ ]+TIME[ ]+[0-9]{0,4}\.[0-9]{0,4})"
Local $sString = " MISSILE 010102 FUZES AGAINST 2 RNG= 0.0 T= 82.846" & @CRLF & _
" TERMINAL POSITION: X= -75933.67 Y= -4469.98 Z= 25000.09" & @CRLF & _
" LAUNCH POSITION: X= -127017.19 Y= -12934.89 Z= 25506.47 MODE CMD_GUIDED_DES_RDR" & @CRLF & _
" AVERAGE VELOCITY= 3375.35" & @CRLF & _
" TERMINAL VELOCITY= 2545.36" & @CRLF & _
" LAUNCHER POSITION: X= -113879.58 Y= -16624.14 Z= 24476.13" & @CRLF & _
" FPOLE= 39848.34" & @CRLF & _
" GUIDANCE TRACKBANK 1 HAS TRACK ON FUZEE SEEKERS CONTRIBUTING INFRA-RED" & @CRLF & _
" ENDGAME SEEKER: IR 1" & @CRLF & _
" A/C 2 IS KILLED AT TIME 82.907" & @CRLF & _
" MISSILE 010102 FUZES AGAINST 3 RNG= 0.0 T= 82.846" & @CRLF & _
" TERMINAL POSITION: X= -75933.67 Y= -4469.98 Z= 25000.09" & @CRLF & _
" LAUNCH POSITION: X= -127017.19 Y= -12934.89 Z= 25506.47 MODE CMD_GUIDED_DES_RDR" & @CRLF & _
" AVERAGE VELOCITY= 3375.35" & @CRLF & _
" TERMINAL VELOCITY= 2545.36" & @CRLF & _
" LAUNCHER POSITION: X= -113879.58 Y= -16624.14 Z= 24476.13" & @CRLF & _
" FPOLE= 39848.34" & @CRLF & _
" GUIDANCE TRACKBANK 1 HAS TRACK ON FUZEE SEEKERS CONTRIBUTING INFRA-RED" & @CRLF & _
" ENDGAME SEEKER: IR 1" & @CRLF & _
" A/C 3 IS KILLED AT TIME 82.907"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")