use strict;
my $str = 'test@домен.ком
test@domain.com
γλώσσα@τομέας.com
<p>info@example.com</p>
<img src="images/svg/ff_logo_hex@1x.svg" alt="formfranska" width="130" />
<picture>
<source media="(min-width: 38em)" srcset="ff_logo_hex@1x.jpg">
<source srcset="ff_logo_hex@1x.jpg">
<img src="ff_logo_hex@1x.jpg" alt="">
</picture>
';
my $regex = qr~<[^<]*(?<!\/(src))>(*SKIP)(*F)|([\w\.\'\-\+]+\@(?:[a-z0-9\.\-\p{L}]+\.)+(?:[a-zA-Z0-9\-\p{L}]{2,24}))~iup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}