import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"<[^<]*(?<!\/(src))>(*SKIP)(*F)|([\w\.\'\-\+]+\@(?:[a-z0-9\.\-\p{L}]+\.)+(?:[a-zA-Z0-9\-\p{L}]{2,24}))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
test@домен.ком
test@domain.com
γλώσσα@τομέας.com
<p>info@example.com</p>
<img src="images/svg/ff_logo_hex@1x.svg" alt="formfranska" width="130" />
<picture>
<source media="(min-width: 38em)" srcset="ff_logo_hex@1x.jpg">
<source srcset="ff_logo_hex@1x.jpg">
<img src="ff_logo_hex@1x.jpg" alt="">
</picture>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)