#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*((^\.)|(^\s)|(\.$)|(\s$)|[\x00-\x1F\x7F<>:\"\/\\|?*]|((?i)^CON$|^PRN$|^AUX$|^NUL$|^COM[0-9]$|^COM[\u00B9\u00B2\u00B3]$|^LPT[0-9]$|^LPT[\u00B9\u00B2\u00B3]$))).*$"
Local $sString = "📂📂文件(夹)名称验证uD83DuDCC2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")