using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*((^\.)|(^\s)|(\.$)|(\s$)|[\x00-\x1F\x7F<>:\""\/\\|?*]|((?i)^CON$|^PRN$|^AUX$|^NUL$|^COM[0-9]$|^COM[\u00B9\u00B2\u00B3]$|^LPT[0-9]$|^LPT[\u00B9\u00B2\u00B3]$))).*$";
string input = @"📂📂文件(夹)名称验证uD83DuDCC2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}