const regex = new RegExp('^(?!.*((^\\.)|(^\\s)|(\\.$)|(\\s$)|[\\x00-\\x1F\\x7F<>:\\"\\/\\\\|?*]|((?i)^CON$|^PRN$|^AUX$|^NUL$|^COM[0-9]$|^COM[\\u00B9\\u00B2\\u00B3]$|^LPT[0-9]$|^LPT[\\u00B9\\u00B2\\u00B3]$))).*$', 'mg')
const str = `📂📂文件(夹)名称验证uD83DuDCC2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}