const regex = /nome:[\s\S]+?(?=e-mail)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('nome:[\\s\\S]+?(?=e-mail)', 'gmi')
const str = `Bla bla bla bla bla NOME: JOSH IDNUMBER: 098766 E-MAIL: josh@gmail.com bla bla bla.
Bla bla bla bla bla NOME: JOAO IDNUMBER: 045344 E-MAIL: josh@gmail.com bla bla bla.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}