re = /^[a-zA-Z0-9-_\.]+$/m
str = 'gabo8-08_2017.com
sany2k8@08_2017.com
sany2k808#
sany2k8-08_2017.com
sany2k808
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end