const regex = /((?:\/\*.*\*\/)?.*\(')?({.*})('\))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\\/\\*.*\\*\\\/)?.*\\(\')?({.*})(\'\\))?', 'gm')
const str = `('{ "common": { "isYandex": "0",  "canRetry": 0, "isYandexPage": "0", "reloadTimeout": "30" }, "rtbAuctionInfo": { "deal": {}, "dspId": 10, "winPrice": 0, "auctionSchedule": [] } }')
/**/('{ "common": { "isYandex": "0",  "canRetry": 0, "isYandexPage": "0", "reloadTimeout": "30" }, "rtbAuctionInfo": { "deal": {}, "dspId": 10, "winPrice": 0, "auctionSchedule": [] } }')
/*{helo}*/helo('{ "common": { "isYandex": "0",  "canRetry": 0, "isYandexPage": "0", "reloadTimeout": "30" }, "rtbAuctionInfo": { "deal": {}, "dspId": 10, "winPrice": 0, "auctionSchedule": [] } }')
/*{helo}*/helo('{ }')
/**/Ya[5248222852932]('{"direct":{"ads":[{"domain"}')
{"direct":{"ads":[{"domain"}
skdE[9835757330451]('{"direct":{"ads":[{"domain"}')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}