package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(?:\{\{if gender ==) (?:"Male"|"Female"|"Both"|"Unknown")\}\}$`)
var str = `{{if gender == "Male"}}
{{if gender == "Female"}}
{{if gender == "Both"}}
{{if gender == "Unknown"}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}