$re = '/^(?:\{\{if gender ==) (?:"Male"|"Female"|"Both"|"Unknown")\}\}$/im';
$str = '{{if gender == "Male"}}
{{if gender == "Female"}}
{{if gender == "Both"}}
{{if gender == "Unknown"}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);