import re
regex = re.compile(r"^\s*((public|private|protected)? *(static)? *(void|int|String|boolean|float|double) +[a-zA-Z_](\w)* *[\(] *(((int|String|boolean|float|double) +[a-zA-Z_](\w)*))* *( *, *int +[a-zA-Z_](\w)* *| *, *String +[a-zA-Z_](\w)* *| *, *boolean +[a-zA-Z_](\w)* *| *, *float +[a-zA-Z_](\w)* *| *, *double +[a-zA-Z_](\w)* *|\))+\s*[{]\s*|( *public +static +void +main *\( *String *(\[\])? * args *(\[\])? *\)\s*[{]\s*))", flags=re.MULTILINE)
test_str = ("public static void salud(String hola,boolean siu) {\n"
"void ultimo(int hola){\n"
"public void saludos(){\n"
"void numeros(String cola, int hola, String si){\n"
"public static void main(String[] args){\n"
"protected String idnombre (int n){\n"
"protected void prueba(String a,int b){\n"
"public static void main(String[] args[]){\n"
"public static void main(String args[]){\n"
"void hola(){}\n"
"void hola(){\n"
"public void main(String id)\n"
"{\n\n\n"
"public void hola ( int c)\n"
"{")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")