const regex = /^\w+\s+:\s+\*{3}\s+(\w.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+\\s+:\\s+\\*{3}\\s+(\\w.*)$', 'gm')
const str = `LOADER_ERROR : *** Failure The UserId, Password or Account is invalid., attempts:1
LOADER_ERROR : *** Time out waiting for a response.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}