re = /([6]\.[1]\.([3-9]$|[1-9]\d{1,}))|([6]\.([2-9]|[1-9]\d{1,})\.\d*)|(([7-9]|[1-9]\d{1,})\.\d*\.\d*)/m
str = '101.23052.0004'
subst = '101.23052.0004'
result = str.sub(re, subst)
# Print the result of the substitution
puts result