#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\n?^SPLIT$\n?"
Local $sString = "Hello there," & @CRLF & _
"SPLIT" & @CRLF & _
"how are you?" & @CRLF & _
"" & @CRLF & _
"Hello there, SPLIT how are you?" & @CRLF & _
"" & @CRLF & _
"Hello there," & @CRLF & _
"SPLIT" & @CRLF & _
"" & @CRLF & _
"Hello there," & @CRLF & _
"SPLIT how are you?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")