using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n?^SPLIT$\n?";
string input = @"Hello there,
SPLIT
how are you?
Hello there, SPLIT how are you?
Hello there,
SPLIT
Hello there,
SPLIT how are you?";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}