using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(do you) (?!lie\b)[a-zA-Z]{3,}";
string input = @"do you a
do you lie
do you lied";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}