$re = '/\[[Pp]rivate\](?=\S)/m';
$str = '[Private]
[private]
[Private]this is a test
not these right?
[Private] this is a test
[Private]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);