import Foundation
let pattern = #"–\s*(\d*[a|b]\d*) (\p{Greek}+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"τὸ μὲν οὖν πρῶτον εἰκὸς τὸν 982b14 ὁποιανοῦν εὑρόντα τέχνην παρὰ τὰς κοινὰς αἰσθήσεις θαυ– 982b15 μάζεσθαι ὑπὸ τῶν ἀνθρώπων μὴ μόνον διὰ τὸ χρήσιμον 982b16 εἶναί τι τῶν εὑρεθέντων ἀλλ´ ὡς σοφὸν καὶ διαφέροντα τῶν 982b17 ἄλλων· πλειόνων δ´ εὑρισκομένων τεχνῶν καὶ τῶν μὲν 982b18 πρὸς τἀναγκαῖα τῶν δὲ πρὸς διαγωγὴν οὐσῶν, ἀεὶ σοφωτέ– 982b19 ρους τοὺς τοιούτους ἐκείνων ὑπολαμβάνεσθαι διὰ τὸ μὴ πρὸς 982b20 χρῆσιν εἶναι τὰς ἐπιστήμας αὐτῶν. ὅθεν ἤδη πάντων τῶν 982b21 τοιούτων κατεσκευασμένων αἱ μὴ πρὸς ἡδονὴν μηδὲ πρὸς 982b22 τἀναγκαῖα τῶν ἐπιστημῶν εὑρέθησαν, καὶ πρῶτον ἐν τούτοις 982b23 τοῖς τόποις οὗ πρῶτον ἐσχόλασαν· διὸ περὶ Αἴγυπτον αἱ μαθη– 982b24 ματικαὶ πρῶτον τέχναι συνέστησαν, ἐκεῖ γὰρ ἀφείθη σχο– 982b25 λάζειν τὸ τῶν ἱερέων ἔθνος. εἴρηται μὲν οὖν ἐν τοῖς ἠθικοῖς 982b26 τίς διαφορὰ τέχνης καὶ ἐπιστήμης καὶ τῶν ἄλλων τῶν ὁμο– 982b27 γενῶν· οὗ δ´ ἕνεκα νῦν ποιούμεθα τὸν λόγον τοῦτ´ ἐστίν, ὅτι 982b28 τὴν ὀνομαζομένην σοφίαν περὶ τὰ πρῶτα αἴτια καὶ τὰς ἀρ– 982b29 χὰς ὑπολαμβάνουσι πάντες· ὥστε, καθάπερ εἴρηται πρότερον, 982b30 ὁ μὲν ἔμπειρος τῶν ὁποιανοῦν ἐχόντων αἴσθησιν εἶναι δοκεῖ 982b31 σοφώτερος, ὁ δὲ τεχνίτης τῶν ἐμπείρων, χειροτέχνου δὲ ἀρ– 982a1 χιτέκτων, αἱ δὲ θεωρητικαὶ τῶν ποιητικῶν μᾶλλον. ὅτι μὲν 982a2 οὖν ἡ σοφία περί τινας ἀρχὰς καὶ αἰτίας ἐστὶν ἐπιστήμη, 982a3 δῆλον. 982a4 Ἐπεὶ δὲ ταύτην τὴν ἐπιστήμην ζητοῦμεν, τοῦτ´ ἂν εἴη 982a5 σκεπτέον, ἡ περὶ ποίας αἰτίας καὶ περὶ ποίας ἀρχὰς ἐπι– 982a6 στήμη σοφία ἐστίν. εἰ δὴ λάβοι τις τὰς ὑπολήψεις ἃς ἔχο– 982a7 μεν περὶ τοῦ σοφοῦ, τάχ´ ἂν ἐκ τούτου φανερὸν γένοιτο μᾶλ– 982a8 λον. ὑπολαμβάνομεν δὴ πρῶτον μὲν ἐπίστασθαι πάντα τὸν 982a9 σοφὸν ὡς ἐνδέχεται, μὴ καθ´ ἕκαστον ἔχοντα ἐπιστήμην 982a10 αὐτῶν·"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2 \1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)