$re = '/((\w;)+\w\n)(-{3,}\n)((\w;)+\w\n)+/';
$str = 'H;e;l;a;a
---------
J;a;c;k;p
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);