# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\\///g;t' <<< "https://example.com.ua/part1/part2/part3/product-123.html"