use strict;
my $str = 'https://example.com.ua/part1/part2/part3/product-123.html';
my $regex = qr/.*\//p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";