$re = '/[^ \w-]/';
$str = '__--===#$#$%#ABZ12;.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;