using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(!!|\$\$)([\w-]+)\1";
string substitution = @"<$2>";
string input = @"My pen cost is !!penCost!! manufactured in $$penYear$$ with colors !!penColor1!! and $$penColor1$$";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}