const regex = /(!!|\$\$)([\w-]+)\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(!!|\\$\\$)([\\w-]+)\\1', 'gm')
const str = `My pen cost is !!penCost!! manufactured in \$\$penYear\$\$ with colors !!penColor1!! and \$\$penColor1\$\$`;
const subst = `<$2>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);