use strict;
my $str = 'My pen cost is !!penCost!! manufactured in $$penYear$$ with colors !!penColor1!! and $$penColor1$$';
my $regex = qr/(!!|\$\$)([\w-]+)\1/mp;
my $subst = '<$2>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";