$re = '/HTTP\/(\d\.\d) (\d\d\d) (.*)/m';
$str = 'HTTP/1.1 200 OK
Content-Type: text/html; charset=utf-8
Server: hhttpp
<!DOCTYPE HTML>
<html><body>
<h1>Hello, World!</h1>
</body></html>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);