$re = '/(?<=CURRENT)(.|\n)*(?=\*Attention: Product Manager)/m';
$str = '*Before and after:
CURRENT
-----------------------------------------------------------------------------
Product ID : J73820
Quantity : 75
Title : Jeans
Brand: XXXX
-----------------------------------------------------------------------------
NEXT ACTION
Increase stock
TO BE
-----------------------------------------------------------------------------
Product ID : J73820
Quantity : 100
Title : Jeans
Brand: XXXX
-----------------------------------------------------------------------------
NEXT ACTION
Add 25 unit
*Attention: Product Manager
*Classification: N/A
C) For urgent product';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);