import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/kiusk\\.ca\\/wp-content\\/uploads.*\\.(?:gif|jpeg|png|psd|bmp|tiff|tiff|jp2|iff|vnd\\.microsoft\\.icon|xbm|vnd\\.wap\\.wbmp|webp|)";
final String string = "https://kiusk.ca/wp-content/uploads/2022/01/dc2.webp";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}