const regex = /https:\/\/kiusk\.ca\/wp-content\/uploads.*\.(?:gif|jpeg|png|psd|bmp|tiff|tiff|jp2|iff|vnd\.microsoft\.icon|xbm|vnd\.wap\.wbmp|webp|)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/kiusk\\.ca\\\/wp-content\\\/uploads.*\\.(?:gif|jpeg|png|psd|bmp|tiff|tiff|jp2|iff|vnd\\.microsoft\\.icon|xbm|vnd\\.wap\\.wbmp|webp|)', 'gm')
const str = `https://kiusk.ca/wp-content/uploads/2022/01/dc2.webp`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}