re = /https:\/\/kiusk\.ca\/wp-content\/uploads.*\.(?:gif|jpeg|png|psd|bmp|tiff|tiff|jp2|iff|vnd\.microsoft\.icon|xbm|vnd\.wap\.wbmp|webp|)/m
str = 'https://kiusk.ca/wp-content/uploads/2022/01/dc2.webp'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end