#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?(DEFINE)(?'Row'(?:<\/td)?>[^>]+>))^ +<tr class="clickable" data-id="(?<AccountID>[^"]+)" data-jobid=\"(?<JobID>[^\"]+)\"(?P>Row)(?<InvoiceID>[^<]+)(?P>Row)(?<Date>[^ ]+)\n +(?P>Row)(?<Status>[^<]+)(?P>Row)(?<Type>[^<]+)(?P>Row)(?<Total>[^<]+)(?P>Row)(?<Balance>[^<]+)(?P>Row)(?<Paid>[^<]+)(?P>Row)(?<Technician>[^<]+)(?P>Row)"
Local $sString = "" & @CRLF & _
" <th>Technician</th>" & @CRLF & _
" <th></th>" & @CRLF & _
" </tr>" & @CRLF & _
" </thead>" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr class="clickable" data-id="277928" data-jobid="3100878">" & @CRLF & _
" <td>3142140</td>" & @CRLF & _
" <td>07/21/2017" & @CRLF & _
" </td>" & @CRLF & _
" <td>Complete</td>" & @CRLF & _
" <td>Initial</td>" & @CRLF & _
" <td>$309.00</td>" & @CRLF & _
" <td>$316.76</td>" & @CRLF & _
" <td>No</td>" & @CRLF & _
" <td>John Smith</td>" & @CRLF & _
" <td>" & @CRLF & _
" <div class="btn-group pull-right">" & @CRLF & _
" <a class="btn btn-small dropdown-toggle" data-toggle="dropdown" href="javascript:;">Action <span class="caret"></span></a>" & @CRLF & _
" <ul class="dropdown-menu">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")