$re = '/[\'"]?(\w+)[\'"]?[ ]?:[ ]?{(.[^}]+)}/ms';
$str = '{
"Employer" : {
Name: \'Sample\',
Age: 23
},
Employer: {
Name: \'Sample\',
Age: 23
},
Employer: {
Name: \'Sample\',
Age: 23
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);