package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sx)(?sx)(\p{Nd})
(?=.*:\1=(\w+)\b)`)
var str = `0 zero
1 ichi
2 ni
3 san
4 shi
5 go
6 roku
7 shichi
8 hachi
9 kyuu
Dictionary:0=0:1=1:2=2:3=3:4=4:5=5:6=6:7=7:8=8:9=9`
var substitution = "\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}