$re = '/課長(?:補佐(?:代理(?:心得)?)?)?/m';
$str = '課長、課長補佐、課長補佐代理、課長補佐代理心得
課長心得、課長代理 -- これにマッチして欲しくないのであれば誤検出
課長次第、課長志願 -- 妥当と思 われるマッチ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);