re = /課長(?:補佐(?:代理(?:心得)?)?)?(?!心得|代理)/m
str = '課長、課長補佐、課長補佐代理、課長補佐代理心得
課長心得、課長代理 -- 部分マッチを排除できた
課長次第、課長志願 -- 妥当と思えるマッチ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end