using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^
(?:
-?\d+(?:\.\d+)?
(?:[+*/-]|$)
)+
(?<![+*/-])
$";
string input = @"53.22+22.11+10*555+62+55.2-3";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}