$re = '/\b11\b,?/';
$str = '22,33,11,44,55,66
11,22,33,44
22,33,44,55,66,11';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);